Le “Pipe”, cette fonction tellement utile !

0

Non le pipe sous IOS n’a rien à voir avec la pipe.

Le pipe est la barre verticale se situe à coté de la touche 1 sur votre clavier:

Azerty

L’IOS permet  l’utilisation du caractère barre verticale (représenté par le caractère |) ou « pipe character » en anglais, pour filtrer le résultat des commandes show. La fonction barre verticale prend le rendement de la commande et l’envoie à une autre fonction, telle que begin ou include. De cette façon, vous pouvez filtrer le rendement « output » pour trouver la section de ce dernier qui vous intéresse. Voici quelques exemples:

Switch#show running-config | begin interface
interface Port-channel1
 description - to Core switch -
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 description outlet D001
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 11
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 description outlet D002
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 11
 spanning-tree portfast
!
[...]

Dans l’image ci-dessus, vous pouvez voir que nous avons saisi la commande show running-config | begin interface. Cette commande démarre le rendement dès la première occurrence du mot interface.

Un autre exemple, cette fois avec la commande include:

Switch#show running-config | include password
no service password-encryption
 password Ceciestunmotdepassetrescomplique!@&5364%
Switch#

 

Comme vous pouvez le voir dans l’exemple ci-dessus, la fonction include n’affiche que les lignes contenant le mot password.

Pour afficher uniquement la section du résultat à propos d’une certaine fonctionnalité, utilisez section :

Switch#show running-config | section vty
line vty 0 4
 password Ceciestunmotdepasseencorepluscomplique!@&5364%)(*&89
 transport input ssh
line vty 5 15
 password Ceciestunmotdepasseencorepluscomplique!@&5364%)(*&89
 transport input ssh
!
Switch#

Vous pouvez voir dans l’exemple ci-dessus que la commande n’a affiché que la section vty de la configuration en cours.

Ce pipe est très pratique lorsque votre configuration contient plusieurs dizaines de lignes de commandes. Vous pouvez filtrer et donc afficher que l’information qui vous est nécessaire.

Alors allez-y, pipez à fond !!

PARTAGER SUR

LAISSER UNE RÉPONSE